This Amerigroup training material requires Macromedia ® FlashTM Player version 7.0 or higher.

Plese ensure that you have this player installed or contact the ServiceDesk to assist.

Macromedia and Flash are trademarks of Macromedia, Inc.